Amazon Kindle discussion

11459 views
Device Related > CAN'T RESET, İT İS JUST FROZEN

Comments Showing 1-11 of 11 (11 new)    post a comment »
dateDown arrow    newest »

message 1: by Merci (new)

Merci | 6 comments Hi all,

My kindle is frozen. I can't sımply reset it. many times ı just was reset it was fine, back alive. But now stuck on the home page where written "slide and release the power to switch to wake".

Reset button does not works any ideas?

Best,
Merci


message 2: by Kelly (new)

Kelly Gressley (kelmay) | 7 comments contact Amazon for help


message 3: by stormhawk (new)

stormhawk | 542 comments Slide and hold the power switch until the light blinks. Release it and wait a couple seconds. Then do the same thing again. Your Kindle should reboot.

I do miss the paperclip reset from the Kindle1. That was easier.


message 4: by IUHoosier (new)

IUHoosier | 93 comments Plug it into a power supply and try it again. Sometimes if the battery is too low, it'll freeze up like that. If that doesn't work, try doing a complete power off and reboot it.

If still nothing, call Amaazon Kindle support. They are fabulous to work with.


message 5: by Tricia (last edited Nov 14, 2011 04:52PM) (new)

Tricia Douglas (teachgiftedkids) | 29 comments This is from Michael's website. It happened to me once too. I went to the Kindle help PDF booklet instructions and fix it from there. Try this first though. The PDF instruction manual is long, but it might be good to have a downloaded copy once in a while.

Kindle Reset Instructions
by Michael Gallagher



You will need to write this down, or try to memorize it, because if it happens to you I’m willing to bet you won’t remember unless you’ve reset your Kindle a few times!

If you would like to print this out, click here to read my post on the Free Kindle Books Plus a Few Other Tips blog to how to capture screen shots on your Kindle.

If this happens to you, you will need to reboot your Kindle. Here is how you do it:

1.Click the “Home” button to get back to your home screen.
2.Click the “Menu” button, and select “Settings.”
3.You will see several options, but “reboot” is not one of those options. Press the “Menu” button again.
4.You will have several options, but choose and click the “Restart” button.
Once you do that, it will take about 1-2 minutes to reboot. Make sure your wireless is on, and the Kindle will go look in the Amazon store to see what is pending to be downloaded and viola! You should be back in business. If you ever need to restart your Kindle, I hope this helps!


message 6: by Merci (new)

Merci | 6 comments ıt sorted out, plugged into a powersupply and it worked....
I am the most happy person...
thank you all for your time and precious help...

Best,
Merci


message 7: by Helen (new)

Helen Lucky. I nearly passed out when mine didn't work.


message 8: by Shaina (new)

Shaina (shainaeg) That happened to my K2. After charging it all night, and trying to plug it into 2 different PCs in order to try to update the software, the guy from Amazon still thought it was my computers and not the Kindle. I eventually convinced him that since the kindle was frozen and neither computer was having any problems it was probably the kindle. Mine was out of warranty but Amazon offered me an amazing deal on a new one.


message 9: by Rory (new)

Rory Davis (drory00) | 1 comments Kindle Screen frozen issue is the most discussing topic between the Kindle users. Simple solution for this thing is hard reset. if hard reset is not the success, just connect with Amazon Kindle support.


message 10: by CBRetriever (new)

CBRetriever | 438 comments I really hope no one's still waiting since November 2011

and there is another frozen screen problem that a hard reset will not fix: accidentally turning on Accessibility Features on a Kindle Fire or a Fire tablet. Those need to be turned off using special gestures. And before you say those aren't Kindles, the 1st & 2nd Gen Fires were and still are called Kindle Fires


message 11: by Jia (new)

Jia Yan | 2 comments I have a paper white for few years and it just happened today. Searched online for answers and brought me here. My son kept trying to do a hard reset and failed multiple times. We held on for 40secs, even as long as one minute it didn't work. We didn't give up and kept trying and trying and suddenly, viola it worked!! Not sure how it happened, just keep pressing and holding probably works!!


back to top