Goodreads Developers discussion

32 views
questions > Problems trying to POST user_status

Comments Showing 1-4 of 4 (4 new)    post a comment »
dateDown arrow    newest »

message 1: by Daniel (last edited Mar 05, 2016 01:36PM) (new)

Daniel (dbmrq) | 19 comments I'm trying to allow my users to update their status using my app.
I managed to authenticate using OAuth and all my calls are working, except the one that actually updates the status.
I'm trying to make this call: https://www.goodreads.com/user_status...
I always get a 404 error. Am I doing something wrong or is there a problem with the API?

Thanks in advance,
Daniel


message 2: by Daniel (last edited Mar 02, 2016 11:40PM) (new)

Daniel (dbmrq) | 19 comments Update: I tried the same call using http instead of https, and then I got "200 OK", but the status update doesn't show on my profile. :(

I tried this because in the python example the url used is this: http://www.goodreads.com/shelf/add_to...

If I try my exact same code with this call I get "201 Created" and it works. If I do it with https instead, though, I get 404.
With the user_status method, on the other hand, neither option works. Using https I get 404, like with the add_to_shelf call, and using http I get 200, but it doesn't work.


message 3: by Daniel (new)

Daniel (dbmrq) | 19 comments Another update: I checked everything that Ettore mentioned on this post, and I also checked the handling of the brackets and tried different ways of doing it; the results are still the same, 200 but no love.


message 4: by Daniel (last edited Mar 07, 2016 04:41PM) (new)

Daniel (dbmrq) | 19 comments I tried my request with Chrome's Postman extension and also on another client for Mac… if I use HTTP the results are the same as in my app, 200 OK but the status isn't updated. If I use HTTPS, though, the first call fails, the second succeeds, the third fails, the fourth succeeds and so on.
So I tried the same on my app, I added two identical HTTPS requests one after the other with 3 seconds of delay between them, and there we have it, it works every other call.

The fact that the same thing happens on Postman and other clients makes me think the problem isn't on my end, though… on the other hand, status updates work every time on the official Goodreads app, and I assume it uses the same call.

Any ideas on this?

I've found a similar thread here, but it seems like it wasn't solved:
https://www.goodreads.com/topic/show/...


back to top