Goodreads Librarians Group discussion

27 views
Book Issues > Search not working properly

Comments Showing 1-7 of 7 (7 new)    post a comment »
dateDown arrow    newest »

message 1: by Erich (new)

Erich | 38 comments Since a couple of days I'm facing weird search issues.

Here's an example, but I've had many more of this kind.

If I search for the title "Pour mourir en février" I get the result: "No results found - sorry!" and the suggestion: "Did you mean: Pour Mourier en f verier" (which doesn't return any result either)

So I tried searching for the Author's name: "Anne-Lise Grobéty". With this search I get 5 results, but none of them is the book I'm looking for. If I click on the author's name http://www.goodreads.com/author/show/... I get 6 books, but still not the one I'm looking for. Only when I click on the "More books by" link, I get 7 books and here is the book I was looking for.

Now I'm really wondering why
- I couldn't find the book by title (is it because of the "é")?
- The book was not shown on the first page of the author search (normally 20 books are shown)
- and also why when clicking on the author's name only 6 books were shown instead of all 7 (normally 10 are shown)

Not to mention that the book has not just been added, so it can't be a "not yet indexed"-issue.

Anyone?


message 2: by Erich (new)

Erich | 38 comments I think my guess about the title search not working is right. If I search only for "Pour mourir en" the book is returned in the search results.

This still doesn't explain the weird behavior of the author results...


message 3: by rivka, Librarian Moderator (new)

rivka | 41655 comments Mod
This is probably a Feedback group issue, as I don't think it has to do with anything librarians can fix.

The search does not know that e and é are (almost) the same -- it thinks they are completely different.

It sounds like some of the issues might be caching issues, but it's hard to tell for sure.


message 4: by Erich (new)

Erich | 38 comments I didn't know of the feedback group. Thanks for the hint.

I know that searching for e and é is not the same, but when I'm searching for février I'd expect it to find février but it doesn't.


message 5: by rivka, Librarian Moderator (new)


message 6: by Erich (new)

Erich | 38 comments Now it does for me too. That's overly weird...


message 7: by rivka, Librarian Moderator (new)

rivka | 41655 comments Mod
That implies that it was indeed a caching issue.


back to top