BookCrossing Reading Room discussion

23 views
BC site wobbles

Comments Showing 1-7 of 7 (7 new)    post a comment »
dateDown arrow    newest »

message 1: by Teotakuu (last edited Jan 22, 2011 10:48PM) (new)

Teotakuu | 25 comments I have been having trouble loading the site for the past day or so but now it won't load at all. Anyone else? Windows XP, latest Firefox if that helps


message 2: by Angela (new)

Angela (innae) | 6 comments I was having trouble just recently too, and when I did finally get on my wings were gone!! (oh no!!) -- anyone know what is going on?? (I too have Firefox)


message 3: by Moem (last edited Jan 23, 2011 04:32AM) (new)

Moem | 12 comments The sit is loading normally for me... I'm running SeaMonkey on XP.
As for the wings thing, there's no way for any of us here to tell what happened. If you feel that they expired too early, writing in to Support is always the best way to get it fixed.


message 4: by Gail (new)

Gail (appleshoelace) I haven't had problems, but I don't go there a lot. I've popped onto chitchat in the past couple of days though, and it's been fine for me. I use Chrome, with Windows 7.

Having said that, just tried to click on it now, and it took quite a while to load. It still loaded though.


message 5: by Cathy (new)

Cathy (cathepsut) No problems today so far. I'm running XP and Firefox...


message 6: by Angela (new)

Angela (innae) | 6 comments Maybe it was just a temporary glitch...and thanks Moem, I did send a message to support :-)


message 7: by Teotakuu (new)

Teotakuu | 25 comments Thanks everyone. It seems to be better this morning, touch wood


back to top