Amazon Kindle discussion

33 views
Device Related > Content Won't Deliver.

Comments Showing 1-5 of 5 (5 new)    post a comment »
dateDown arrow    newest »

message 1: by Cat (new)

Cat  | 15 comments It's been a week ow since any new content has been delivered to my Kindle.
I have restarted. I have gone to Content and Devices and hit Deliver on all the new purchases. I have had the kindle connected to both WiFi and 3G internet, but nothing is working. Can anyone help please?


message 2: by Mjbett (new)

Mjbett | 1 comments Did you deliver to the correct device?
Could you have accidentally deregistered your kindle? (Admittedly, it’s hard to do accidentally but it’s a possibility)
Does it need an update?
Other than that...I would think your troubleshooting would have resolved most issues. You’re probably going to end up having to contact CS.
Good luck.


message 3: by CBRetriever (new)

CBRetriever | 454 comments have you rebooted (not restarted) your Kindle by holding the power button on for a full 30 seconds?

have you tried rebooting your router?

have you tried syncing (menu option or icon) and then looking in your Archives/Cloud/All tab and finding the book and selecting it and downloading it?


message 4: by Cat (new)

Cat  | 15 comments Done all of those things. I'm going to have to go the Cs route.


Art (aka Whistler Reads) (art-whistlerreads) | 29 comments having the sameo problemo w/kindle for pc


back to top