Goodreads Librarians Group discussion

158 views
Book Cover Help > problem with alternate cover editions

Comments Showing 1-16 of 16 (16 new)    post a comment »
dateDown arrow    newest »

message 1: by Shay (new)

Shay Roberts (shayroberts) | 21 comments Hello! I recently created alternate cover editions for two of my books, 9780996726108 and 9780996726160. I thought I had followed the instructions correctly, but it's been almost a week and the old versions are still persisting and the reviews haven't come over to the new default editions. Have I done something wrong? Any advice appreciated. Thanks!

~Shay~


message 2: by Paula (new)

Paula (paulaan) | 7029 comments You did not combine them, they are now combined


message 3: by Paula (last edited Jul 31, 2016 12:29PM) (new)

Paula (paulaan) | 7029 comments Follow instructions in msg 4 in link below to set default edition

https://www.goodreads.com/topic/show/...


message 4: by Shay (new)

Shay Roberts (shayroberts) | 21 comments Paula, thanks for the super-fast response! I really appreciate your help. BTW, these instructions on the help page for creating an alternate cover edition don't mention that you have to combine them. Might be a useful thing to add...
https://www.goodreads.com/help/show/8...

PS: when I went to make book two the primary edition, I got an error message saying it was already the default edition. Also, the new alternate cover edition of book one is missing from my dashboard now, so I can't make it the default.


message 5: by Paula (new)

Paula (paulaan) | 7029 comments If you used the add new edition link on the book page to add new books, the the combine is done automatically so use that link in the future


It's the second one in this list

https://www.goodreads.com/work/editio...


message 6: by Shay (new)

Shay Roberts (shayroberts) | 21 comments Thanks Paula, I will make a note of that! On my author dashboard, the new covers have disappeared and only the old covers remain. Do I need to start over?


message 7: by rivka, Librarian Moderator (new)

rivka | 45058 comments Mod
Setting a new cover as default will not effect your dashboard, which only you can see. It will change what shows on your author page and when doing searches by author name or book title.


message 8: by Shay (new)

Shay Roberts (shayroberts) | 21 comments Hi Rivka! Unfortunately, the new covers are not showing on my author page or through searches. If I go to my author page without logging in first, or do a goodreads search for my books, I still see the old covers. The new covers seem to be gone now.


message 9: by rivka, Librarian Moderator (new)

rivka | 45058 comments Mod
Have you set the new covers as the defaults, with the instructions Paula linked in post #2 of this thread?


message 10: by Shay (new)

Shay Roberts (shayroberts) | 21 comments I did that before, and in both cases it told me the new cover was already the default version. I just went to my author dashboard to try it again, but of course I can't because the new covers are gone.

I did notice a message that said the old covers had been manually made to be the default edition. If I clear that setting, will the new covers reappear and let me make them the default? I can certainly try that if you think it would help.

When I first did this, I tried to change the default cover immediately after creating the alternate cover edition. And I got that error saying that my new cover was already the default cover. Perhaps the alternate cover had not yet had time to be absorbed by the system, or perhaps the problem is that the new and old version weren't combined yet when I tried to change the default.


message 11: by lethe (new)

lethe | 14582 comments Shay wrote: "I did that before, and in both cases it told me the new cover was already the default version."

That was because the books were not combined yet (a single edition is automatically the default). If you click on 'all editions' you can select the edition you want to make the default and then proceed as before.


message 12: by Shay (new)

Shay Roberts (shayroberts) | 21 comments Hi Lethe! So from my author dashboard, I click on the title of my book. Then I scroll down and click on "All Editions"? When I do this, I do see the new cover, but when I click on it, I am now in the reader interface with no option to edit, so I can't set it as the default.

Should I go into my author dashboard and clear out the previous default first?


message 13: by rivka, Librarian Moderator (new)

rivka | 45058 comments Mod
You cannot set defaults from the dashboard, and there is no way to undo a default; only to set a new edition as the default.

You should have an edit option from the book page of every edition that you are first-listed author on.


message 14: by Shay (new)

Shay Roberts (shayroberts) | 21 comments Rivka, in my author dashboard, when I click on "edit book details", there is an option that says "This book is manually set to be the primary edition of this work. (Clear Manual Setting )". The "clear manual setting" part is hyperlinked and appears to be a command. I haven't clicked on it yet though because I don't want to make things worse. This is the option I was referring to earlier.

BTW, I did finally find the "edit details" option on my book page. It was grayed out so I didn't notice it before. I was able to change the default to the new cover!

I think everything is working now. *crosses fingers*

Thank you everyone for all your help. I can imagine that this is as frustrating for you as it is for me. :)


message 15: by rivka, Librarian Moderator (new)

rivka | 45058 comments Mod
Shay wrote: "The "clear manual setting" part is hyperlinked and appears to be a command."

You are right. I had forgotten we added that option.

But if you are going to set a different edition manually (as you did), clearing that first is an unnecessary extra step. It's only useful if you want it to go back to selecting a default based on which edition is most shelved, instead of one you have selected.


message 16: by Shay (new)

Shay Roberts (shayroberts) | 21 comments Good to know, thank you!


back to top