Goodreads Author Feedback Group discussion

103 views
Ask Goodreads > blog quit working

Comments (showing 1-11 of 11) (11 new)    post a comment »
dateDown arrow    newest »

message 1: by Lori (new)

Lori (writerlorismith) | 11 comments My blog quit working on May 25. No idea why. Can it be fixed?

(The blog is in Wordpress.)

thanks!

Lori Smith
www.writerlorismith.com


message 2: by Gwendolyn (last edited Jun 28, 2012 01:59AM) (new)

Gwendolyn (DrGwen) | 9 comments Lori;

RSS is no longer picking up site feed.

On your Wordpress dashboard, go to Privacy and make sure that it is set to "Allow search engines to index this site."

Then, on your Goodreads author profile, edit and re-enter the link to your Wordpress blog.

It should sync within 12 hours of the next time you do a blog update.


message 3: by Lori (new)

Lori (writerlorismith) | 11 comments Thanks, Gwendolyn.

The Privacy setting was already set to that.

I went in to edit / re-add the feed URL. I tried to add this URL: http://www.writerlorismith.com/feed/

And I get this message: There was a problem saving that blog: External feed url doesn't seem to exist

Although the feed works for other sites (like Amazon).

This is the same error I got when first trying to add my blog to Goodreads. Patrick was somehow able to get it to add anyway, but I don't think he did anything differently than what I've done.

I'm stumped!


message 4: by Mona (new)

Mona Karel (MonaKarel) | 17 comments On your Wordpress dashboard, go to Privacy and make sure that it is set to "Allow search engines to index this site."

Thank you! Now my blog shows up here and I don't have to put in a link every time!


message 5: by Gwendolyn (last edited Jun 29, 2012 05:48PM) (new)

Gwendolyn (DrGwen) | 9 comments Lori;

Yes, I know the feed from your blog is present. The simple fact that you or I can open it in a browser page should be enough to confirm that... and I know Goodreads doesn't have a problem with Wordpress because I and many other authors use the platform for our blogs...

But... and its a big one... the 'argument' in the code that most every site uses to link to the RSS blog-feed depends upon the structure that looks something like 'blogname'.'servicename'/feed.

The simple fact that you own your own domain 'breaks' that argument.

So, try an experiment for me. Replace the link with feed://www.writerlorismith.com/ and see what happens.

Meanwhile, I'm going to try a few things and I'll get back to you here.


message 6: by Gwendolyn (last edited Jun 28, 2012 01:41PM) (new)

Gwendolyn (DrGwen) | 9 comments Lori;

A 'Duh' moment just occurred. I need to know;

Is your site hosted at Wordpress, by a hosting provider or on a private server?

The reason I ask is that the 'easy' fix for those who do private domain hosting is to map a sub-domain to your site that points to the blog content.

Example: 'blog-name.domain-name.com' This would map to the domain-name but would be seen as a valid 'Blog' by services like Goodreads.

The downside of this is paying for it. If you're doing your own hosting (private server) and you own your domain, you can simply customise your DNS tables.

With a hosting service (like Wordpress) there would be a 'maintenance fee' involved. (Wordpress charges 13 USD/year for this. External hosting companies charge anywhere from 49-125 USD/year.


message 7: by Patrick, Director, Author Marketing (new)

Patrick Brown | 276 comments Mod
I actually think this is part of an ongoing issue on our end and may not have anything to do with the settings on Lori's blog. We're looking into it. Thanks for the feedback so far.


message 8: by Gwendolyn (new)

Gwendolyn (DrGwen) | 9 comments Patrick;

If you'd be so kind as to let us know what the programmers find.

Thanks.


message 9: by Lori (new)

Lori (writerlorismith) | 11 comments Thanks, Patrick! Glad to know it's being looked into.

Gwendolyn - I think that might be expensive for me. I use Dreamhosters.


message 10: by Robin (new)

Robin (RobinTalley) | 1 comments Chiming in because I'm having this same issue. I came across this thread when I did a Google search for this error. I'm trying to sync my blog from robintalley.wordpress.com/feed/ and when I enter it I get the same error message Lori did.


message 11: by Laurie (new)

Laurie London (LaurieLondon) | 4 comments I'm having the same issue too. All of a sudden, it's not picking up my blogger blog feed.


back to top

unread topics | mark unread